Author Topic: word of warning  (Read 1844 times)

TarotDragoon

  • Founder
  • *
  • Posts: 446
word of warning
« on: August 25, 2012, 05:00:20 pm »
Trying to mod in new prefabs WILL FUCK ALL YOUR OTHER PREFABS UP!!

now I'm stuck with about a hundred ships with random spiky bits sticking out fucking everywhere with no idea how to put it all back. because I can't just delete the prefabs because whatever new prefab it has turned into will take ALL THE FUKING BLOCKS WITH IT!! >:( >:( >:(

just a word to the wise people.
Micah- Loving all the ships here Tarot!

PURPLE UNTO DEATH!!! (or maybe blue)

Niwantaw

  • Founder
  • Eternal Skipper O.Q
  • *
  • Posts: 1448
  • Grille'd
Re: word of warning
« Reply #1 on: August 25, 2012, 05:09:03 pm »
It worked fine back when I tried it.

Just add a new folder with the .obj, texture, diffuse & text document then add another line in solids.xml...
"God damnit why does everything have to be in sweedish? I don't understand shit"-Davee

<Strait_Raider> "The Big 4 could be equipped with a Bren gun or a 3 inch mortar..."
<Strait_Raider>That's like... my two favorite things.
     Put together.
     That's like... Kate Upton in a Tiger

mamastoast

  • Founder
  • *
  • Posts: 1010
Re: word of warning
« Reply #2 on: August 26, 2012, 06:49:52 am »
can't you just fix it by copying the entities folder into a fresh install?

MrVorgra

  • Founder
  • *
  • Posts: 1401
  • RAWR!
Re: word of warning
« Reply #3 on: August 26, 2012, 10:30:10 am »
Explain what you did to produce this issue and ill fix it, (although I expect I know exactly what you have done)
Real Men drive vehicles without knowing how fast they are moving or how much fuel remains in the tank.

iamwearingpants

  • Founder
  • *
  • Posts: 2
  • The lunatic is on the grass..... GET OFFA MY LAWN
Re: word of warning
« Reply #4 on: August 27, 2012, 01:35:00 am »
I had basically the same thing happen to me. Turns out, adding a line to the middle of the .xml makes the prefab-loader-whatever flip it's flapjacks and load the wrong thing. So, like identifying what prefab to be loaded is by order in the file or something. Try taking that line out and sticking it in the back, the ships should go back to normal, because nothing actually changed in the saves AFAIK. Hope this helps!  :D

TarotDragoon

  • Founder
  • *
  • Posts: 446
Re: word of warning
« Reply #5 on: August 27, 2012, 07:12:53 am »
I had basically the same thing happen to me. Turns out, adding a line to the middle of the .xml makes the prefab-loader-whatever flip it's flapjacks and load the wrong thing. So, like identifying what prefab to be loaded is by order in the file or something. Try taking that line out and sticking it in the back, the ships should go back to normal, because nothing actually changed in the saves AFAIK. Hope this helps!  :D

this was indeed the problem however now I have holes all over my ship from overzealous deletion. hence the first angry message. added to that my 3x3x4 engine prefab still doesn't work. crashes the game whenever I place it, the normal seem all screwed up.

yes. when adding your own prefabs ALWAYS PUT THE CODE ON THE BOTTOM.
Micah- Loving all the ships here Tarot!

PURPLE UNTO DEATH!!! (or maybe blue)

MrVorgra

  • Founder
  • *
  • Posts: 1401
  • RAWR!
Re: word of warning
« Reply #6 on: August 27, 2012, 11:49:58 pm »
He he, yes, thought it was obvious where to place it, to fix the crashing issue its likely you have an issue with your targeting in your line of code in the XML file, also check that there are spaces in all the right spots and no spelling errors, the crashing won't be caused by the actual model or texture. (or at least shouldn't be)
Real Men drive vehicles without knowing how fast they are moving or how much fuel remains in the tank.